Welcome new members! Introduce yourself here.

scottsbro23

New Member
[quote name='ratster' timestamp='1309841751' post='161203']

Greetings from East Tn.

[/quote]



Welcome aboard...post up some pics of the T!
 

ratster

New Member
[quote name='scottsbro23' timestamp='1309905560' post='161215']

Welcome aboard...post up some pics of the T!

[/quote]



You would be disappointed !! It's just your plain ole 07 XE with ugly steel wheels.For now anyways......
 

scottsbro23

New Member
[quote name='ratster' timestamp='1310344480' post='161268']

You would be disappointed !! It's just your plain ole 07 XE with ugly steel wheels.For now anyways......

[/quote]



Nah I would be disappointed if you said "It's just a plain ole Ford F150"..lmao
 

krh2

Administrator
[quote name='scottsbro23' timestamp='1310423635' post='161273']

Nah I would be disappointed if you said "It's just a plain ole Ford F150"..lmao

[/quote]

Yup! Post up brudda. Hell, Scotssbro has an OG '04 LE n my Gina kicks Franks arse. Ill let Scotssbro decipher that. Welcome to da Spot!
 

honeykeeper

New Member
[quote name='ratster' timestamp='1309841751' post='161203']

Greetings from East Tn. [/quote]



Greetings from next door in WNC.....how far are you from Asheville/Black Mountain area?



Welcome to Titan Hot Spot........
 

honeykeeper

New Member
[quote name='Big Dog David' timestamp='1271701045' post='156735']

Complete Titan noob here. Name is David. I just bought my first Titan, love it so far. I bought a 2010 Titan Pro-4X. I am trying to find a good mudhole down here in the Nashville area to really go try this thing out (while listening to XM radio and warming my butt in the heated seats of course).



I am a biker. I ride a Big Dog K9, big ol' chopper. I needed something as nice as the big to pull it if necessary. So, the Titan it is. Glad to be here, hope to learn a lot from all you guys.





[/quote]







Welcome and do hang around........we have a few more bikers here like steves.....great pics.........post up!.........
[font="Arial, Verdana"]
 

Andy B

New Member
Finally a real Titan Forum.....LOve these friggen "gentleman" hot rods...



"05 Deepwater king cab, 18"chromies,remapped ecu,fram cold air intale with K&N cone filter,Flowmaster super 40 custom bent exhaust,powerslot rotors and Hawk pads...Damn this truck stops better than my Lincoln lS v8! So how the hell do I get the pics on board? Can't seem to figure it out!!! H>E>L>P!!!!
 

Attachments

krh2

Administrator
[quote name='Andy B' timestamp='1311522659' post='161383']

Finally a real Titan Forum.....LOve these friggen "gentleman" hot rods...



"05 Deepwater king cab, 18"chromies,remapped ecu,fram cold air intale with K&N cone filter,Flowmaster super 40 custom bent exhaust,powerslot rotors and Hawk pads...Damn this truck stops better than my Lincoln lS v8! So how the hell do I get the pics on board? Can't seem to figure it out!!! H>E>L>P!!!!

[/quote]





Nice color! As for posting pics you can either do what you did above and upload direct from your puter or use a hosting site. I use photobucket. Its free. Upload your pics, then under each pic will be 4 boxes. You want to copy the
 

J Burdette

New Member
Hello, my name is J and I am new to the titan seen.Once a die hard ford and dodge person now the owner of a 05 nissan titan 2wd. goodbye ford and dodge i really love the titan. Its a charcoal grey with the charcoal grey rims and interior crewcab and i love the hell out of it .we hope to improve the truck more we bought with a k and n filter accel superchip and flowmaster 50 series already on it . and yes it does run ,i already have a chevy and a ford under my belt lol.hope to learn more on titans and meet new people i am out of weatherford tx.
 

honeykeeper

New Member
[quote name='J Burdette' timestamp='1312736553' post='161556']

Hello, my name is J and I am new to the titan seen.Once a die hard ford and dodge person now the owner of a 05 nissan titan 2wd. goodbye ford and dodge i really love the titan. Its a charcoal grey with the charcoal grey rims and interior crewcab and i love the hell out of it .we hope to improve the truck more we bought with a k and n filter accel superchip and flowmaster 50 series already on it . and yes it does run ,i already have a chevy and a ford under my belt lol.hope to learn more on titans and meet new people i am out of weatherford tx.

[/quote]

Welcome to Titgan Hot Spot Jurdette.... <img src='http://www.titanspot.com/Titan/public/style_emoticons/<#EMO_DIR#>/006.gif' class='bbc_emoticon' alt=':smt006' /> Plenty of Titaneers from your neck-o-the woods and plenty to learn and enjoy here. enjoy.... <img src='http://www.titanspot.com/Titan/public/style_emoticons/<#EMO_DIR#>/003.gif' class='bbc_emoticon' alt=':-D' />
 

houdon720

New Member
Just joined today, got smart and found a nice '05 Titan of my own! I've been reading the posts about the IPDM issues and have two questions.

1. My low beam headlights do not work, It's not a fuse, it maybe a relay and I have only 0.08 volts DC at my sockets, even tried switching relays but it did not work. help.

2. I have a friend who has an IPDM in his truck ('06 Titan) with a model # 284B7-ZC00A. Mine is the original and wondered if we can switch them to test my headlight issue.

I think you all have a really great site here and am glad to join. Thanks, houdon720
 

honeykeeper

New Member
[quote name='houdon720' timestamp='1312748437' post='161561']

Just joined today, got smart and found a nice '05 Titan of my own! I've been reading the posts about the IPDM issues and have two questions.

1. My low beam headlights do not work, It's not a fuse, it maybe a relay and I have only 0.08 volts DC at my sockets, even tried switching relays but it did not work. help.

2. I have a friend who has an IPDM in his truck ('06 Titan) with a model # 284B7-ZC00A. Mine is the original and wondered if we can switch them to test my headlight issue.

I think you all have a really great site here and am glad to join. Thanks, houdon720

[/quote]

There are two fuses each for high and low beams.....two blue 15 amp ones are on the top of the middle row for lo-beams.........go ahead and try the other IPDM to see if it's a relay issue......it's quick enough to try. Let us know which relay it is as it's not labeled on the module or owners manual.

Good luck.
 

houdon720

New Member
Thanks for the pointers. Verified the fuses to be good, no go. We tried my buddie's IPDM and everything worked! I'm shopping around for one now.

Mine has a part # 284B6-7S002 and my buddies was part # 284B7-ZC00A. Must be a malfunction within the IPDM. Are the IPDM's recalled or is it just the ECM relay? I did notice in a post from you, (excellent post by the way!) that my ECM relay had a NAIS 4 relay instead of the NAIS 5 relay. So I figure this was someone or some dealers quick fix. I haven't had any issues with stalling or anything, just the headlights. At least now I know where my problem is!

Again, I'm new to this site, but with this kind of friendly support, who'd want another truck! Thanks, houdon720
 

honeykeeper

New Member
[quote name='houdon720' timestamp='1312856542' post='161580']

Thanks for the pointers. Verified the fuses to be good, no go. We tried my buddie's IPDM and everything worked! I'm shopping around for one now.

Mine has a part # 284B6-7S002 and my buddies was part # 284B7-ZC00A. Must be a malfunction within the IPDM. Are the IPDM's recalled or is it just the ECM relay? I did notice in a post from you, (excellent post by the way!) that my ECM relay had a NAIS 4 relay instead of the NAIS 5 relay. So I figure this was someone or some dealers quick fix. I haven't had any issues with stalling or anything, just the headlights. At least now I know where my problem is!

Again, I'm new to this site, but with this kind of friendly support, who'd want another truck! Thanks, houdon720

[/quote]

Good to hear you made some progress.

If everything works with another complete board I would reinstall your malfunctioning board and swap the relays one at a time with your buds board until you find the faulty relay for the low beam lights. Do not switch the ECU or Fog light relays. When you find which one it is try to find one somewhere like DigiKey or buy a complete new board from Brian our Nissan Vendor here and mention TitanSpot to get a good discount.

There is a recall on the known relay to go bad but with your problem I would ask you SM if they will replace the board under warranty or recall.



Let us know how it goes.
 
Top