clicking sound coming from dash

redman

New Member
I have an 06 titan LE, and over the last month or so everytime I start or shut off the truck I get this strange "clicking" sound coming from my dash. Sounds like its either behind the instrument cluster or the stereo not sure. It clicks anywhere from 10 seconds to a full minute or two. Its a very fast clicking and very loud. Sounds too loud to be a relay. Any thoughts as to what it is? 
 

05titanfedup

New Member
Mine does that. I was told it was the aculator for the ac maybe something like that. lol I'm a determined woman who is learning to repair my Titan since it's breaking me money wise. Lol



Sent from my iPhone using Tapatalk
 

jdmartin

Active Member
Whenever you shut the truck off, the heater/defroster doors reset so as to prevent a vacuum in the truck. When you start it up, they go back to wherever they're supposed to be based on your settings. I would guess this is what you're hearing. My truck does it. So does my other car (a newer Kia). The delay on the Kia is a little longer so you wouldn't notice it unless you sat in the car for a minute or so, whereas with the truck it starts faster. 
 

honeykeeper

New Member
Whenever you shut the truck off, the heater/defroster doors reset so as to prevent a vacuum in the truck. When you start it up, they go back to wherever they're supposed to be based on your settings. I would guess this is what you're hearing. My truck does it. So does my other car (a newer Kia). The delay on the Kia is a little longer so you wouldn't notice it unless you sat in the car for a minute or so, whereas with the truck it starts faster.

Same here... no problem.
 
Top