Jump to content



Welcome to TitanSpot - Nissan Titan Forum


Sign In 

Create Account
Welcome to TitanSpot - Nissan Titan Forum, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of TitanSpot - Nissan Titan Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members.
  • Access the members list and photo gallery.
 
Guest Message by DevFuse

Photo

Titan engine problems


No replies to this topic

#1 boudreaux7721

boudreaux7721
  • Members
  • 2 posts

Posted 23 November 2017 - 08:31 AM

Not to make this a long story the short of it . Engine is barely running like it's spitting and sputtering is I bring it to Nissan for diagnostic. They tell me my engine is shot the cats were sucked in throw the intake and I need a new engine 5,000 to 10,000 !!!
So this is where it gets interesting
Now mine you I have a little mechanic experience so I'm like yea ok it's not looked up ,it still runs I got this
So I start googling the VK56DE my engine all I can get it the Nissan dealer ship
At this time I'm trying to get mechanics to look at it their all telling me Nissan has the codes an they will not share it .
At this point I'm getting mad so I Google ( engine close to the VK56DE )Ferrari comes and I'm like yea ok what ever F-ing Google right
So I decide to have fun with it so I'm scrolling through pics.and what do I see it's a titan engine low an behold Ferrari and Nissan have the same type of V8 engines
So I start like for info on the Ferrari v8 and they had problems with the cats they were getting sucked in, the exhaust was to small
Now it's two years later I'm pissed
So I start working on it
I took out injectors, intake manifold, spark plugs, O2 sensors, and cats
Cleaned everything and put it all back
It took one week now that's working on it after work
And now it is running great!
09460903a4a2c83c829d9b02744f2023.jpg9c49ae34ca97f033224caeef34d97294.jpghttp://cloud.tapatal..._103911_001.mp4

Sent from my SM-N950U using Tapatalk



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq